[Solved] Download failed Could not open handle for fopen()

wordpress upgrade fopen error

After installing wordpress blog if new updates for wordpress core files or any plugin upgrade is available, then wordpress had inbuilt update notification feature which automatically update wordpress with a single click. but on some of hosting when you try to upgrade from admin dashboard,you will get error saying “Download failed Could not open handle for fopen()“.

There are two main reasons that cause this error – Could not open handle for fopen(). Normally this error occur if you wordpress blog is hosted at IIS and some cases it may arise under cpanel PHP web hosting.

When you try to upgrade  any of the wordpress plugins you will  get the same “Download failed. Could not open handle for fopen().

Most often the first time you try to use the automatic upgrade for WordPress or a plugin you will be taken to the form that asks for your FTP login information.

Even though your FTP credential is valid, you will get that error.

How to fix ‘Download failed Could not open handle for fopen()’ error

To fix Download failed Could not open handle for fopen() error you simply need to check permission of the wordpress installation sub directories.

Make sure that ‘wp-include‘ and ‘wp-content‘ directory set to 755 permission. also If you are hosting  WordPress blog on IIS you should make directory writable.

Comments are closed.

Join over 1000+ Bloggers
who get daily WordPress Tips from ShoutGeek!
RecentPosts